Just nu i M3-Nätverket
Gå till innehåll
PheelipKarlsson

MiGiC, svensk Midiconverter för gitarr (VST/AU)

Rekommendera Poster

Funderade på hur en au-variant av MiGiC skulle köras i Logic ?

Som en Midi-fx plugg på ett software-inst track med sidechain mot gitarrens inputkanal ?

Eller tänker jag bakvänt nu ?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Jag har testat att lira med både migic och en vanlig gura kanal på rec och det funkar så det borde ju bli lika när det körs som plugin. Men man kanske kan dra nytta av att sidechaina den också.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Grymt!! :D Måste säga att det var riktigt kul att få se någon annan spela genom programmet och jag tyckte det visst det var bra spelat! :) Kul!!

 

 

Vad kul! :) Mac eller Win?

 

Mac OSX 10.9.5 med Logic Pro 9.1.8.

 

 

Jag har kört in två-tre Sylenth-synthar och en Vengeance Kick och testat med impOscar - funkar jättebra, men blir pyttelite latency.

 

Rapport (och låt) kommer senare:-)

 

 

 

mvh/Peter

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Funderade på hur en au-variant av MiGiC skulle köras i Logic ?

Som en Midi-fx plugg på ett software-inst track med sidechain mot gitarrens inputkanal ?

Eller tänker jag bakvänt nu ?

 

Det blir en effekt du lägger på ett audio track :) Så fort du sätter igång pluggen skapas ett nytt midi-instrument som heter MiGiC, precis som du hade kopplat in ett USB-keyboard!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Mac OSX 10.9.5 med Logic Pro 9.1.8.

 

 

Jag har kört in två-tre Sylenth-synthar och en Vengeance Kick och testat med impOscar - funkar jättebra, men blir pyttelite latency.

 

Rapport (och låt) kommer senare:-)

 

mvh/Peter

 

Kul!

 

Jag undrar vad det är med Logic som gör att det blir extra latency.. Är du säker på att du har aktiverat "low latency mode" ? Vad har du för buffer sizes? Får kanske skaffa Logic själv och testa lite för att lösa det här..

 

Spelar ju själv genom Ableton och där finns absolut ingen märkbar latency när jag har 32 i buffer size i MiGiC och 64 i Ableton. Du råkar inte ha någon standalone-synth installerad? Typ Massive/FM8 eller dylikt där du kan testa med låg buffer size.

 

Tackar för att du vill testa MiGiC i ett sådant här tidigt skede :)

 

/ P

Redigerad av PheelipKarlsson

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Det verkar som att det funkar bra om man ställer in Logics buffersize till 64. Jag har letat efter och hittat lite info om Logic och latency men jag vet inte om det går att överföra till live triggning och latency från en mjukvaru applikation.

 

Är på paddan nu så jag återkommer med länk senare.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven
Postad (redigerade)

Här är den kanske nån har nytta av tipset, jag ska testa och se om det blir lite tajtare efter korrigeringen.

 

http://play.macprovi...om/logic9207/18

Redigerad av Burnin Sven

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven
Postad (redigerade)

Goda nyheter för Logic folket tipset funkar latencyn är i princip borta.

 

Trots att jag på den här maskinen var tvungen att göra testet mellan in och ut gången på mitt delta 44 enbart och inte delta 44 och datorns interna (då jag inte hade tillgång till rätt kabel för att koppla mellan) så funkar det ändå riktigt bra med värdet för latency kompenseringen jag fick med hjälp av testet i länken ovan.

Redigerad av Burnin Sven

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Grymt! Lägger upp tipset på min webbsida under en FAQ.

 

STORT tack för att du hittat detta och bekräftat att det funkar, jobbar för tillfället vidare med AU/VST/AAX och har snart återskapat de flesta komponenterna i GUIt så det går framåt! :)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Låter intressant så jag ska försöka hitta lite tid för att testa också. Skaffade en Fishman Triple Play-gitarr förra året, den triggar fint som standalone men jag får en liten men alltför märkbar latency när jag kör den via Reaper... har inte haft tid att finjustera alltför mycket så det visar väl mest hur mycket tid jag har att lägga på spelandet. :/

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Kul!

 

Jag undrar vad det är med Logic som gör att det blir extra latency.. Är du säker på att du har aktiverat "low latency mode" ? Vad har du för buffer sizes? Får kanske skaffa Logic själv och testa lite för att lösa det här..

 

Spelar ju själv genom Ableton och där finns absolut ingen märkbar latency när jag har 32 i buffer size i MiGiC och 64 i Ableton. Du råkar inte ha någon standalone-synth installerad? Typ Massive/FM8 eller dylikt där du kan testa med låg buffer size.

 

Tackar för att du vill testa MiGiC i ett sådant här tidigt skede :)

 

/ P

 

Varsågod! Har testat under några timmar igår och den funkar väldigt bra. Har kört in syntbas, lead-synt, pad och lite annat på ett testprojekt. Latencyn jag pratade om gäller inte när man spelar, utan vad som faktiskt spelas in, det blir en aning fördröjning (har tagit skärmdumpar på det). Jag funderade lite i de banor som finns i det tipset som Burnin Sven tipsade om: att man kan kompensera för latencyn i Logic (bara man känner till hur mycket det är).

 

Jag kör alltid både Pro Tools och Logic i lägsta latency, som är 32 samples - vilket (enligt Logic) är 6,8 ms.

 

 

 

mvh/Peter

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Uppdatering 2015-03-21 - Nu är jag klar med en första version av VSTn (32 och 64 bitar) för Windows som finns att ladda hem på min webbsida http://www.bituosity.com. Mitt mål är att det ska vara mycket enkelt att ladda hem pluggen och komma igång så jag skulle vara mycket tacksam för feedback på detta! Kommer fortsätta utvecklingen med AU/VST/AAX för Mac och jag beräknar att ha en release klar om någon vecka. Därefter kommer jag sätta igång med ytterligare en release till Linux och Raspberry Pi.

 

Lycka till! :)

Redigerad av PheelipKarlsson

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Låter intressant så jag ska försöka hitta lite tid för att testa också. Skaffade en Fishman Triple Play-gitarr förra året, den triggar fint som standalone men jag får en liten men alltför märkbar latency när jag kör den via Reaper... har inte haft tid att finjustera alltför mycket så det visar väl mest hur mycket tid jag har att lägga på spelandet. :/

 

Finns nu som VST och jag upplever mindre latency med VSTn än med standalone. Så jag skulle vara mycket tacksam om du ville ladda hem MiGiC som VST och testa den som plugin i Reaper.

 

/P

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

MiGiC-test 11/3-2015

 

 

DAW: Logic Pro 9.1.8 (1700.67) (32 bit)

 

Ljudkort: Digidesign MBox 2 Pro 32 samples/6,8 ms latency

 

Trummor: Peter Fredlander (Superior Drummer 2 - Monster Midi Pack)

 

1. Solina Lowstrings i Logics sampler ESX 24:

MiGiC - Sens 89 Speed 50, Dynamics och Legato ikryssade.

 

2. Sylenth Deep Phase Pad: samma inställningar.

 

3. SampleMoog: fick ej att funka.

 

4. Sylenth Wet Sub Bass: samma inställningar.

 

5. Mello (mellotron sample player): funkade inte.

 

6. M-Tron Pro Classic Flute: samma inställningar som tidigare i MiGiC.

 

7. 2 st Sylenth Gemini Lead: samma inställningar. En av dessa spelade jag in med MiGiC och den andra med ett CME Z-Key 88 (gissa vilken som är vilken?).

 

8. Gitarr Samick Stratta: dubbade lead-slingan med min gamle Samick för att ha som referens.

 

 

OBS! Är varken gitarrist eller keyboardist, så alla otajtheter bör förbises:-)

 

 

Detta lilla test kanske inte visar MiGiCs hela potential, men jag tycker att den funkar väldigt bra trots att den är så tidigt in i utvecklandet. Det går säkert att laborera mer med inställningar i MiGiC och på så sätt få ett bättre resultat. Det blir pyttelite latency, som är svår att höra, tycker jag.

 

Jag testade också att delaykompensera (Burnin Svens videotips), men det verkar bara påverka ljudinspelning och inte midit som spelas in (blev samma latency på det inspelade midit).

 

 

mvh/Peter

 

 

Ljudprov:

 

https://soundcloud.com/peter-roos-1/petes-54-jam-with-migic-guitar-to-midi-converter

Redigerad av Sleap

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Det verkar funka bra låter fint det här

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

MiGiC-test 11/3-2015

 

 

DAW: Logic Pro 9.1.8 (1700.67) (32 bit)

 

Ljudkort: Digidesign MBox 2 Pro 32 samples/6,8 ms latency

 

Trummor: Peter Fredlander (Superior Drummer 2 - Monster Midi Pack)

 

1. Solina Lowstrings i Logics sampler ESX 24:

MiGiC - Sens 89 Speed 50, Dynamics och Legato ikryssade.

 

2. Sylenth Deep Phase Pad: samma inställningar.

 

3. SampleMoog: fick ej att funka.

 

4. Sylenth Wet Sub Bass: samma inställningar.

 

5. Mello (mellotron sample player): funkade inte.

 

6. M-Tron Pro Classic Flute: samma inställningar som tidigare i MiGiC.

 

7. 2 st Sylenth Gemini Lead: samma inställningar. En av dessa spelade jag in med MiGiC och den andra med ett CME Z-Key 88 (gissa vilken som är vilken?).

 

8. Gitarr Samick Stratta: dubbade lead-slingan med min gamle Samick för att ha som referens.

 

 

OBS! Är varken gitarrist eller keyboardist, så alla otajtheter bör förbises:-)

 

 

Detta lilla test kanske inte visar MiGiCs hela potential, men jag tycker att den funkar väldigt bra trots att den är så tidigt in i utvecklandet. Det går säkert att laborera mer med inställningar i MiGiC och på så sätt få ett bättre resultat. Det blir pyttelite latency, som är svår att höra, tycker jag.

 

Jag testade också att delaykompensera (Burnin Svens videotips), men det verkar bara påverka ljudinspelning och inte midit som spelas in (blev samma latency på det inspelade midit).

 

 

mvh/Peter

 

 

Ljudprov:

 

https://soundcloud.com/peter-roos-1/petes-54-jam

 

Det här var ju riktig kul :) Skulle det vara okej om jag länkar detta på webbsidan? Tänkte lägga till en sektion med lite klipp från användare. Tycker du spelar grymt, att inte SampleMoogen funkar lär väl inte vara relaterat till MiGiC hoppas jag?

 

Kan berätta att jag skaffat Logic själv och upplever mer latency än i t.ex. Ableton, förstår inte varför... har någon någon ide så är jag mycket intresserad. Dock kan jag meddela att latencyn blir betydligt mindre när man kör MiGiC som AU :D Har någon veckas jobb innan den är klar men kommer slänga upp en uppdatering så fort jag har något att dela med mig av. Ser samma tendenser med VST kontra standalone på Windows.

 

Tack för demon

Redigerad av PheelipKarlsson

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Har fått igång AUn till Logic nu och kan bekräfta att det är betydligt mindre latency än tidigare uppmätt i Logic (till och med jämfört med demon jag gjorde i Ableton!). Ska kompilera en 32 och en 64 bitars version och slänga ihop en installer i dagarna.

Redigerad av PheelipKarlsson

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Jag laddar ner och testar

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det här var ju riktig kul :) Skulle det vara okej om jag länkar detta på webbsidan? Tänkte lägga till en sektion med lite klipp från användare. Tycker du spelar grymt, att inte SampleMoogen funkar lär väl inte vara relaterat till MiGiC hoppas jag?

 

Kan berätta att jag skaffat Logic själv och upplever mer latency än i t.ex. Ableton, förstår inte varför... har någon någon ide så är jag mycket intresserad. Dock kan jag meddela att latencyn blir betydligt mindre när man kör MiGiC som AU :D Har någon veckas jobb innan den är klar men kommer slänga upp en uppdatering så fort jag har något att dela med mig av. Ser samma tendenser med VST kontra standalone på Windows.

 

Tack för demon

 

Tack så mycket och varsågod själv:-)

 

Länka du på bara, 5/4-delsgrejen var bara en kul övning, men inte speciellt bra mixad. Den var tänkt för att försöka utröna hur man skulle spela och hur mycket latency det blev. Jag kunde inte höra någon direkt skillnad mellan MiGiC och när jag spelade på mitt CME-keyboard (dubbad Sylenth-lead i höger respektive vänster kanal).

 

Att några syntar inte funkade beror INTE på MiGiC, dessa är nog inte skrivna på rätt sätt. Jag ville bara kolla vilka av mina mjukvaror som funkade.

 

Ska testa AU-versionen av din plugg också:-)

 

mvh/Peter

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Och där var dom uppe! :) Nu finns MiGiC som Audio Unit och VST för mac på http://www.bituosity.com i både 64 och 32 bitar. Finns intresse för AAX kan jag även bygga det.

 

Lycka till!

 

AAX hade ju varit kul (för oss som använder Pro Tools också).

 

/P

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Logic får inte till det med migic det går inte att öppna pluginen dessvärre. Jag kör sista Logic pro 9 i 32 bitarsläget. Jag kör 32 bitar för att det ska gå att ta in filmer och mecka ljudet på dom. Hur avinstallerar man pluginen?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Det här är på Musikdatorn så jag drar väl hem standalone versionen också men den vet vi ju att den funkar i och med att jag testade den på Video datorn.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det här är på Musikdatorn så jag drar väl hem standalone versionen också men den vet vi ju att den funkar i och med att jag testade den på Video datorn.

 

Villen version av OS X kör du? Jag har bara haft tillgång till 10.9 och 10.10 själv. Misstänker att jag skulle behöva få tag på ett äldre system och bygga på det. Pluggen ligger på /Library/Audio/Plug-ins/Components och där kan du ta bort den, det är bara en fil. Kan eventuellt ha hittat en lösning, skulle du kunna köra AU-manager och skicka resultatet till mig via mail?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Mountainlion 1.8.5 tror jag ska gå ner och kolla och återkommer men au manager resultatet

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Ska dra och handla först sen tänkte jag dra igång en sändning och lira lite så då kan fixa det

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven
Postad (redigerade)

Jo det var 10.8.5 ML jag har och så här säger audio units manager

 

--------------------------------------------------

VALIDATING AUDIO UNIT: 'aufx' - 'Plug' - 'Manu'

--------------------------------------------------

Manufacturer String: Bituosity

AudioUnit Name: MiGiC

Component Version: 1.0.0 (0x10000)

Component's Bundle Version: 1.0.0

 

* * PASS

--------------------------------------------------

TESTING OPEN TIMES:

COLD:

2015-03-22 21:42:26.520 auvaltool[486:f07] Error loading /Library/Audio/Plug-Ins/Components/MiGiC.component/Contents/MacOS/MiGiC: dlopen(/Library/Audio/Plug-Ins/Components/MiGiC.component/Contents/MacOS/MiGiC, 262): Symbol not found: ___exp10

Referenced from: /Library/Audio/Plug-Ins/Components/MiGiC.component/Contents/MacOS/MiGiC

Expected in: /usr/lib/libSystem.B.dylib

in /Library/Audio/Plug-Ins/Components/MiGiC.component/Contents/MacOS/MiGiC

FATAL ERROR: OpenAComponent: result: -50,0xFFFFFFCE

 

 

validation result: couldn't be opened

 

updating properties of AU MiGiC by Bituosity...FAILED!

 

 

 

FAILED!

 

Jag tror inte att det har att göra med den här datorn då den bygger på Quo computers AOS moderkort som är det enda i världen än så länge i alla fall som det går att installera OS X på utan hacking tricks/chameleon etc eller nåt.

Redigerad av Burnin Sven

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Testade AU-varianten idag (Logic 9 och OSX 10.9.5) och den funkade bra - betydligt lägre latency än standalone-versionen. Det enda som jag noterade var att den "nollställdes" varje gång jag öppnade den i ett fönster, dvs. alla inställningar gick tillbaka till ursprungsnivå.

 

 

 

 

mvh/Peter

 

 

PS: det var inte några som helst problem att installera AU-pluggen och inte några som helst problem att köra igång den heller. Logic var helt nöjt.

Redigerad av Sleap

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven

Standalone varianten verkar funka på den här datorn också så det är nog nåt med Mountainlion i så fall om sleap fick igång AU versionen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gäst Burnin Sven
Postad (redigerade)

Leker lite med standalone versionen. På den här datorn har jag ett Saffire pro 10 i/o kort med ett delay på 10 samples.

Redigerad av Burnin Sven

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Registrera ett nytt konto i våran gemenskap. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×